Jump to content

  •  

Staff applications open!

We are currently in need of more staff members. Feel you are ready to take on the tasks of being a Community Team Member? Apply today here: http://invision-viru...f-applications/
IV Management

- - - - -

HTTP Error 500 when installing language on IPB 3.4


  • This topic is locked This topic is locked
6 replies to this topic

#1 DriLL

DriLL

    Newbie

  • Member
  • Pip
  • 9 posts

Posted 23 June 2020 - 04:07 AM

Describing the problem:
  • 1. What problem are you having? HTTP Error 500 when installing language on IPB 3.4
  • 2. What were you doing when the problem occurred?

    Nothing, just installing the language, I always had this problem to install any language version. But before it was not necessary, I could use the forum in English, since it received people from other countries. But now the forum is especially for Brazil. So I need to install the Portuguese language, but this error has prevented me for a long time. This is the first time I try to support to solve this
  • 3. Picture/Video of the problem: (an error code should be pasted here, please use "code" bbcode)

    https://imgur.com/a/XFD6jCb
Here are the images for you to understand. When I press the "import" button, then error 500 appears to me. Then the language installs with errors, in the screenshots of the link there is the demo of the forum in English, and consequently in Portuguese with bug, due to the error 500 that prevents me from installing the language normally
  • 4. An error log should be pasted here via screenshot or in code for detailed preview
Versions:
  • 5. What version of IP.B are you using? 3.4.9
  • 6. What PHP version are you running? 5.5
Required links:
  • 7. Who is your web hosting provider? infinityfree, I'm using for testing and solving these small problems before hiring a host
  • 8. What is your board URL? (you can send it via PM if we ask you for it) PM
IP.B Package/Miscellaneous
  • 9. Where did you download the IP.B installation package? (please provide a link) here at invision-virus
  • 10. What did you try to solve the problem? nothing, what I tried in the past didn't work
  • 11. What username and password can we use to see the problem.
Customization:
  • 12. Do you have any hooks/mods installed? No
  • 13. Are you using a custom or default skin? Default

Edited by DriLL, 23 June 2020 - 04:08 AM.


#2 neptunus

neptunus

    Invision-Virus Nerd

  • Member
  • PipPipPipPipPip
  • 553 posts

Posted 23 June 2020 - 05:26 AM

View PostDriLL, on 23 June 2020 - 04:07 AM, said:

Describing the problem:
If I look at the picture/screenshot you added, it seems to me that there is something very wrong with the files you are using.
Namely, the files in this folder don't have extensions (they're probably hidden), but the extension is visible in the language file you specified, there's an extension (interesting why if others don't have extensions) and there is something more what looks also weird. Namely, if it is an .xml file, why is the icon for this file a WinRAR icon?
So it looks like you have there some kind weird compote, but not the correct files.
How do You comment such a things?
And after all, I see there You must upload .xml file, but on this screenshot I see file with such a name language.xml.gz - why .gz file if must be .xml file?
And why is file name "language", if should be "Portuguese" as You said?

Edited by neptunus, 23 June 2020 - 05:36 AM.


#3 DriLL

DriLL

    Newbie

  • Member
  • Pip
  • 9 posts

Posted 23 June 2020 - 10:56 PM

Hi man, Ty for the support. All the IPB 3.4 translation files I find come in this format. I noticed that the host limits the upload time to 20 seconds, and it is not possible to change. I believe this may be the problem, the file needs more than 20 seconds to upload. I will try to find another translation, one that is just .xml ... I believe I will not find, all that I find come in .xml.gz format




#4 neptunus

neptunus

    Invision-Virus Nerd

  • Member
  • PipPipPipPipPip
  • 553 posts

Posted 23 June 2020 - 11:39 PM

View PostDriLL, on 23 June 2020 - 10:56 PM, said:

Hi man, Ty for the support. All the IPB 3.4 translation files I find come in this format. I noticed that the host limits the upload time to 20 seconds, and it is not possible to change. I believe this may be the problem, the file needs more than 20 seconds to upload. I will try to find another translation, one that is just .xml ... I believe I will not find, all that I find come in .xml.gz format

.gz is a compressed file, but you must unpack it before uploading.
Don't you think it makes sense to do this if you need an .xml file that is compressed in .gz format.

And the question again, why don't you post in the right section for your problem?

#5 DriLL

DriLL

    Newbie

  • Member
  • Pip
  • 9 posts

Posted 23 June 2020 - 11:54 PM

IPB itself asks for the file in .xml.gz. Here is the correct section, the problem is not in the file

Edited by DriLL, 23 June 2020 - 11:55 PM.


#6 Robinson

Robinson

    Community Team

  • Community Team Leadership
  • 557 posts
  • LocationIV Strip Club

Posted 25 June 2020 - 02:10 AM

Your problem might be the host, its not recommended to use free hosting.

Do not PM me or any Staff member with support related questions

| Community Rules | News | License FAQ | License Reset | Join Discord | Donator Info |

  

           Posted Image


#7 Robinson

Robinson

    Community Team

  • Community Team Leadership
  • 557 posts
  • LocationIV Strip Club

Posted 03 July 2020 - 06:06 PM

No response in a week, locked, if you need more assistance, feel free to make another post.

Do not PM me or any Staff member with support related questions

| Community Rules | News | License FAQ | License Reset | Join Discord | Donator Info |

  

           Posted Image





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users