Jump to content

  •  

Staff applications open!

We are looking for dedicated members to join the Community Team to help enforce the community rules and make IV a better place for everyone.
Do you think you have what it takes to join? Apply here: http://invision-viru...f-applications/
IV Management

- - - - -

Issue with API IPB V4.2.0


  • Please log in to reply
6 replies to this topic

#1 mloneya212

mloneya212

    Newbie

  • Donator
  • Pip
  • 9 posts

Donator

Posted 25 July 2019 - 04:04 PM

Describing the problem:
  • 1. Currently it seems the Rest API is not recognizing my api key when making a request
  • 2. Im using the url https://domain.com/a...llo&key=KEYHERE i have also tried changing the & out for a ?
  • 3.
    {
    	"errorCode": "2S290\/6",
    	"errorMessage": "NO_API_KEY"
    }
    
  • 4. Error log shows same error as above
Versions:
  • 5. 4.2.0
  • 6. 7.1
Required links:
  • 7. virmatch vps
  • 8. will pm if asked for url
IP.B Package/Miscellaneous
  • 9. this site
  • 10. I tried a few things google suggested, like editing the .htaccess file
  • 11. dm me if u want to see it
Customization:
  • 12. No
  • 13. No


#2 waha005

waha005

    Community Team

  • Community Team
  • 226 posts

Posted 25 July 2019 - 05:38 PM

The error code says that the API Key is not sended in request.

2s290/6 => No Api key send in the request 

Check also did you make the request to the valid request where you should include the api key.
About me:
- I am programmer, i know PHP, HTML, CSS, JS, JQUERY, C++, C#, Perl, Python excellent. Also i'm working with Photoshop for designs, logo, banners etc.



Best regards,
Waha005

#3 mloneya212

mloneya212

    Newbie

  • Donator
  • Pip
  • 9 posts

Donator

Posted 25 July 2019 - 05:49 PM

View Postwaha005, on 25 July 2019 - 05:38 PM, said:

The error code says that the API Key is not sended in request.

2s290/6 => No Api key send in the request

Check also did you make the request to the valid request where you should include the api key.

Yea thats the issue, im sending the api key at the end like the documentation shows, but it isnt registering

#4 waha005

waha005

    Community Team

  • Community Team
  • 226 posts

Posted 25 July 2019 - 05:55 PM

PM me with instructions where you put request, what api key is it and maybe authorization to see what's going wrong.


For things like this, you should have basic knowledge of how it works Rest Api
About me:
- I am programmer, i know PHP, HTML, CSS, JS, JQUERY, C++, C#, Perl, Python excellent. Also i'm working with Photoshop for designs, logo, banners etc.



Best regards,
Waha005

#5 mloneya212

mloneya212

    Newbie

  • Donator
  • Pip
  • 9 posts

Donator

Posted 27 July 2019 - 11:22 AM

Just want to notify this is not fixed *

#6 waha005

waha005

    Community Team

  • Community Team
  • 226 posts

Posted 28 July 2019 - 09:56 PM

View Postmloneya212, on 27 July 2019 - 11:22 AM, said:

Just want to notify this is not fixed *

You have been put invalid url to the rest api. Did you resolved your issue now ?
About me:
- I am programmer, i know PHP, HTML, CSS, JS, JQUERY, C++, C#, Perl, Python excellent. Also i'm working with Photoshop for designs, logo, banners etc.



Best regards,
Waha005

#7 Lucas_SAntos

Lucas_SAntos

    Newbie

  • Member
  • Pip
  • 0 posts
  • LocationVilnius

Posted 02 August 2019 - 11:26 PM

The error code says that the API Key is not sended in request.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users