Jump to content

  •  

Staff applications open!

We are looking for dedicated members to join the Community Team to help enforce the community rules and make IV a better place for everyone.
Do you think you have what it takes to join? Apply here: http://invision-viru...f-applications/
IV Management

- - - - -

Having trouble migrating my site.


  • This topic is locked This topic is locked
6 replies to this topic

#1 aritech

aritech

    Member

  • Member
  • PipPip
  • 14 posts

Posted 03 June 2019 - 10:36 AM

Describing the problem:
  • 1. What problem are you having? I am trying to move my site from shared webhosting to one of my VPS's that isnt really getting used so i thought i might put it to good use. After moving all files and database and configuring the .php file to switch over to the new database, i get a 500 error that tells me absolutely nothing, so i cant really move forward without knowing what the problem is.
  • 2. What were you doing when the problem occurred? Migrating my site.
  • 3. Picture/Video of the problem: (an error code should be pasted here, please use "code" bbcode) For some reason there is no error code. 500 error I guess. I get two different errors. One when i just go to the ip of the site, if i go to domain/admin i get a different error. Links: https://gyazo.com/bc...35943a142f6e5a8 first error when just visiting the ip, https://gyazo.com/64...9e7e4d0f3957311 error i get when i visit domain/admin
Versions:
  • 4. What version of IP.B are you using? 4.4.2
  • 5. What PHP version are you running? 7.2
Required links:
  • 6. Who is your web hosting provider? it was nfoservers lite webhosting, now its just an LAMP from servercheap, unbuntu 18.04 vps
  • 7. What is your board URL? (you can send it via PM if we ask you for it) http://162.212.152.36/
IP.B Package/Miscellaneous
  • 8. Where did you download the IP.B installation package? (please provide a link) http://invision-viru...llusion-nulled/
  • 9. What did you try to solve the problem? Several things, i removed the files from my server and went through a brand new installation so i could see that my VPS was meeting all of the requirements for various modules and such to be installed, it was. I then took a second look at my conf_global.php and database settings and URL setting were configured correctly.
  • 10. What username and password can we use to see the problem. You cant even get to the site so I dont think this is neccesary, but if it is please PM me and i will set you up with an account.
Customization:
  • 11. Do you have any hooks/mods installed? IP content, that is it.
  • 12. Are you using a custom or default skin? custom, vulpes 2.0.5

Thanks in advance for any tips/advice you might have!

#2 Invincibility

Invincibility

    Retired Contributor

  • Retired Contributor
  • PipPipPipPipPip
  • 123 posts

Donator

Posted 04 July 2019 - 07:27 PM

Hello.

PHP error 500 looks like a permission error in the FTP for me.
Missing/wrong files in the FTP could cause issues too.
The second screenshot shows that a specific class can't be found.

I would recommend to install the forum from the scratch to avoid any kind of problems in the future.
If this is no option for you, maybe someone else has an idea.

#3 cold

cold

    Management Team

  • Community Management
  • 648 posts

Donator

Posted 04 July 2019 - 08:36 PM

View Postaritech, on 03 June 2019 - 10:36 AM, said:

Describing the problem:
  • 1. What problem are you having? I am trying to move my site from shared webhosting to one of my VPS's that isnt really getting used so i thought i might put it to good use. After moving all files and database and configuring the .php file to switch over to the new database, i get a 500 error that tells me absolutely nothing, so i cant really move forward without knowing what the problem is.
  • 2. What were you doing when the problem occurred? Migrating my site.
  • 3. Picture/Video of the problem: (an error code should be pasted here, please use "code" bbcode) For some reason there is no error code. 500 error I guess. I get two different errors. One when i just go to the ip of the site, if i go to domain/admin i get a different error. Links: https://gyazo.com/bc...35943a142f6e5a8 first error when just visiting the ip, https://gyazo.com/64...9e7e4d0f3957311 error i get when i visit domain/admin
Versions:
  • 4. What version of IP.B are you using? 4.4.2
  • 5. What PHP version are you running? 7.2
Required links:
  • 6. Who is your web hosting provider? it was nfoservers lite webhosting, now its just an LAMP from servercheap, unbuntu 18.04 vps
  • 7. What is your board URL? (you can send it via PM if we ask you for it) http://162.212.152.36/
IP.B Package/Miscellaneous
  • 8. Where did you download the IP.B installation package? (please provide a link) http://invision-viru...llusion-nulled/
  • 9. What did you try to solve the problem? Several things, i removed the files from my server and went through a brand new installation so i could see that my VPS was meeting all of the requirements for various modules and such to be installed, it was. I then took a second look at my conf_global.php and database settings and URL setting were configured correctly.
  • 10. What username and password can we use to see the problem. You cant even get to the site so I dont think this is neccesary, but if it is please PM me and i will set you up with an account.
Customization:
  • 11. Do you have any hooks/mods installed? IP content, that is it.
  • 12. Are you using a custom or default skin? custom, vulpes 2.0.5
Thanks in advance for any tips/advice you might have!


You probably don't have all the required dependencies installed. Please upload the following file and visit it in your browser to see if your server has all the required dependencies.

https://anonfile.com...Ycx1nb/ips4_php
Community Rules | IV Discord | News
discord: cold#0001
steam: /id/hitmarker

#4 aritech

aritech

    Member

  • Member
  • PipPip
  • 14 posts

Posted 09 July 2019 - 10:47 AM

View Postcold, on 04 July 2019 - 08:36 PM, said:

You probably don't have all the required dependencies installed. Please upload the following file and visit it in your browser to see if your server has all the required dependencies.

https://anonfile.com...Ycx1nb/ips4_php
Uploaded file, shows all dependencies installed and ready to go.

View PostInvincibility, on 04 July 2019 - 07:27 PM, said:

Hello.

PHP error 500 looks like a permission error in the FTP for me.
Missing/wrong files in the FTP could cause issues too.
The second screenshot shows that a specific class can't be found.

I would recommend to install the forum from the scratch to avoid any kind of problems in the future.
If this is no option for you, maybe someone else has an idea.

Just for testing purposes, and the VPS is one that holds no crucial information what so ever at the moment, I put everthing in the www directory to 777 permissions. yes i understand this goes against alot of OPSEC, but theres not anything worth protecting, this is just a trial.

Any other thoughts?

Edited by aritech, 09 July 2019 - 10:55 AM.


#5 neptunus

neptunus

    Invision-Virus Nerd

  • Member
  • PipPipPipPipPip
  • 485 posts

Posted 10 July 2019 - 05:31 AM

View Postaritech, on 09 July 2019 - 10:47 AM, said:

Uploaded file, shows all dependencies installed and ready to go.
...  I put everthing in the www directory to 777 permissions.
Any other thoughts?
all files must be 644(in some cases conf_global.php may be 664 and if You use web cron service, then web.php must be 777) and all folders 755

#6 waha005

waha005

    Community Team

  • Community Team
  • 220 posts

Posted 23 July 2019 - 12:47 AM

Author of the thread, does you resolved this issue if not here are some steps to resolve this issue:

- Download requirements script for IPS4 then upload to your server, and see what you don't have.
- Upload all files to your VPS, an error saying that some class can't find it seems that you doesn't uploaded all files

Your ticket will be closed on 23.07 without possibility to reopen if not answered from author of the thread if it is solved or not.
About me:
- I am programmer, i know PHP, HTML, CSS, JS, JQUERY, C++, C#, Perl, Python excellent. Also i'm working with Photoshop for designs, logo, banners etc.



Best regards,
Waha005

#7 waha005

waha005

    Community Team

  • Community Team
  • 220 posts

Posted 24 July 2019 - 06:37 AM

This support request has been closed due to the inactivity of the author of this thread.
About me:
- I am programmer, i know PHP, HTML, CSS, JS, JQUERY, C++, C#, Perl, Python excellent. Also i'm working with Photoshop for designs, logo, banners etc.



Best regards,
Waha005




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users