Jump to content

  •  

- - - - -

Setting up HTTPS with Ubuntu 18.04?


  • Please log in to reply
5 replies to this topic

#1 CookieCutter

CookieCutter

    Member

  • Member
  • PipPip
  • 10 posts

Posted 14 April 2019 - 08:37 AM

So I have a VPS I pay for and I routed it through Cloudflare to use my domain, however I host multiple things through my VPS and was hoping to have the HTTPS handled at the VPS level in case someone managed to find the IP address. Any ideas how I could go about doing this?

#2 Robinson

Robinson

    Community Team

  • Community Team
  • 208 posts
  • LocationIV Strip Club

Posted 14 April 2019 - 03:16 PM

Do you use IPS/IPB?

#3 KahunaElGrande

KahunaElGrande

    Community Team Leadership

  • Community Team Leadership
  • 48 posts
  • LocationUnited States

Posted 14 April 2019 - 03:23 PM

Https doesn't protect you from anything. It's meant to protect the client from man-in-the-middle attacks. Which is something you can't control at the point. If your server is setup correctly and someone tries to connect with IP they should get a error page unless you have it setup in a way that makes your IP a alias for your website. But IPS only allows a single connect address and will automatically redirect the client to match your website url in the config file.

So if your config file says https://domain.tld they will be redirect to https://domain.tld always

#4 CookieCutter

CookieCutter

    Member

  • Member
  • PipPip
  • 10 posts

Posted 14 April 2019 - 03:33 PM

View PostRobinson, on 14 April 2019 - 03:16 PM, said:

Do you use IPS/IPB?
I currently have all the files set, I just have to request a license which I'll get to soon hopefully.

View PostKahunaElGrande, on 14 April 2019 - 03:23 PM, said:

If your server is setup correctly and someone tries to connect with IP they should get a error page unless you have it setup in a way that makes your IP a alias for your website. But IPS only allows a single connect address and will automatically redirect the client to match your website url in the config file.

So if your config file says https://domain.tld they will be redirect to https://domain.tld always
It routes through CloudFlare, but I did point it to my IP address which I think might just be using it as an alias then. If I access the site using the domain, it's using https since I had it toggled through CloudFlare, but if I try accessing the site with my IP address it still shows the IPS install page. Is there a way to disable direct access to the website with IP?

#5 KahunaElGrande

KahunaElGrande

    Community Team Leadership

  • Community Team Leadership
  • 48 posts
  • LocationUnited States

Posted 14 April 2019 - 03:35 PM

Are you using nginx or Apache?

#6 CookieCutter

CookieCutter

    Member

  • Member
  • PipPip
  • 10 posts

Posted 14 April 2019 - 03:46 PM

View PostKahunaElGrande, on 14 April 2019 - 03:35 PM, said:

Are you using nginx or Apache?
Currently I'm using nginx.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users