Jump to content

  •  

Staff applications open!

We are looking for dedicated members to join the Community Team to help enforce the community rules and make IV a better place for everyone.
Do you think you have what it takes to join? Apply here: http://invision-viru...f-applications/
IV Management

- - - - -

Problem Update 4.4.2


  • This topic is locked This topic is locked
4 replies to this topic

#1 TheFighter

TheFighter

    Newbie

  • Member
  • Pip
  • 7 posts

Posted 08 April 2019 - 06:17 AM

Describing the problem:
1. What problem are you having?
I have a 500 error code after updating the site

2. What were you doing when the problem occurred?
Updating the site

3. Picture/Video of the problem: (an error code should be pasted here, please use "code" bbcode)
Sun, 07 Apr 2019 18:46:53 +0000
ParseError: syntax error, unexpected '?', expecting variable (T_VARIABLE) (0)
#0 [internal function]: IPS\IPS::autoloader('IPS\\Request')
#1 /var/www/untopan/ips/system/Dispatcher/Front.php(394): spl_autoload_call('IPS\\Request')
#2 /var/www/untopan/ips/system/Dispatcher/Front.php(38): IPS\Dispatcher\_Front->checkCached()
#3 /var/www/untopan/ips/system/Dispatcher/Dispatcher.php(109): IPS\Dispatcher\_Front->init()
#4 /var/www/untopan/ips/index.php(13): IPS\_Dispatcher::i()
#5 {main}
#0 /var/www/untopan/ips/init.php(661): IPS\_Log::log('ParseError: syn...', 'uncaught_except...')
#1 [internal function]: IPS\IPS::exceptionHandler(Object(ParseError))
#2 {main}

Versions:
4. What version of IP.B are you using?
4.3.6

5. What PHP version are you running?
PHP 7.0.33

Required links:
6. Who is your web hosting provider?
The site is hosted on a dedicated server OVH

7. What is your board URL? (you can send it via PM if we ask you for it)
http://www.untopan.fr/
I restored the site in 4.3.6

IP.B Package/Miscellaneous
8. Where did you download the IP.B installation package? (please provide a link)
directly on this site, in the category download

9. What did you try to solve the problem?
Check for server updates (PHP, Apache, ...)
Check permissions

10. What username and password can we use to see the problem.
No specific user, the site is inaccessible with error code 500

Customization:
11. Do you have any hooks/mods installed?
Cookie Notice

12. Are you using a custom or default skin?
Nerva 4.3.x
I try to put the default theme before starting the update but the problem is the same

Edited by TheFighter, 08 April 2019 - 06:21 AM.


#2 Robinson

Robinson

    Community Team

  • Community Team Leadership
  • 365 posts
  • LocationIV Strip Club

Posted 08 April 2019 - 05:22 PM

If I'm not mistaken, 4.4.2 need at least php version 7.1/7.2 -  you have PHP 7.0.33

Do not PM me or any Staff member with support related questions

| Community Rules | News | License FAQ | License Reset | Join Discord | Donator Info |

  

           Posted Image


#3 TheFighter

TheFighter

    Newbie

  • Member
  • Pip
  • 7 posts

Posted 08 April 2019 - 08:15 PM

Thank you very much for the answer.
It works perfectly
Thank you very much for the answer. It works perfectly

#4 neptunus

neptunus

    Invision-Virus Nerd

  • Member
  • PipPipPipPipPip
  • 495 posts

Posted 08 April 2019 - 08:17 PM

Mr Robinson  said absolutely correctly - to install IPS 4.4.x minimum is php 7.1

#5 Robinson

Robinson

    Community Team

  • Community Team Leadership
  • 365 posts
  • LocationIV Strip Club

Posted 08 April 2019 - 08:21 PM

No problem fella! :) glad i could help out.

Closed and moved to solved.

Do not PM me or any Staff member with support related questions

| Community Rules | News | License FAQ | License Reset | Join Discord | Donator Info |

  

           Posted Image





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users