Jump to content

  •  

Staff applications open!

We are looking for dedicated members to join the Community Team to help enforce the community rules and make IV a better place for everyone.
Do you think you have what it takes to join? Apply here: http://invision-viru...f-applications/
IV Management

IPBoard 4.3.6 Not Detecting php.ini Change


  • This topic is locked This topic is locked
11 replies to this topic

#1 patrick8996

patrick8996

    Member

  • Donator
  • PipPip
  • 22 posts
  • LocationOregon

Donator

Posted 23 November 2018 - 05:12 AM

Describing the problem:

I just recently installed the 4.3.6 forum software as a fresh install. I have had previous versions of IP board successfully installed at my current host before. I am running into an issue where I cannot upload anything bigger than 2MB into my themes upload, application upload, or plugins upload. I have googled this issue and I have modified my php.ini settings through my hosts cPanel and have verified the changes to upload_max_filesize = as well as post_max_size = through the file manager and they are both set to 100M. I have also verified that the .htaccess has the same settings reflected from the php.ini settings.

Versions:

Forum Version: 4.3.6
PHP Version: 7.2

Required links:

​Web host provider is gnu-host.
Board URL can be provided in a PM

IP.B Package/Miscellaneous

Download package from this site here: http://invision-viru...sion-nulledzip/

I have attempted to fix this issue by contacting my hosting provider and they have verified that my php.ini is being wrote properly.

I have changed the settings through the cPanel interface as well as verified the text by viewing the php.ini through the file manager.

Customization:

This is a fresh install with just one theme installed that was under the 2MB restriction.

#2 seventeen82

seventeen82

    Advanced Member

  • Member
  • PipPipPip
  • 70 posts

Donator

Posted 23 November 2018 - 05:44 AM

check your phpinfo to see if the changes are reflected there. Who is your web host?

you can access phpinfo by going into admin cp -> support -> support / there is a link on the top right that says phpinfo, click on that.

or you can upload a phpinfo file into your root and run that.

#3 patrick8996

patrick8996

    Member

  • Donator
  • PipPip
  • 22 posts
  • LocationOregon

Donator

Posted 23 November 2018 - 06:10 AM

View Postseventeen82, on 23 November 2018 - 05:44 AM, said:

check your phpinfo to see if the changes are reflected there. Who is your web host?

you can access phpinfo by going into admin cp -> support -> support / there is a link on the top right that says phpinfo, click on that.

or you can upload a phpinfo file into your root and run that.

I run my own web hosting reseller site but my base hoster is https://gnu-host.com/

My phpinfo shows a 2M max file upload so I am a bit confused as to why this is not reflecting my settings through the php.ini

#4 seventeen82

seventeen82

    Advanced Member

  • Member
  • PipPipPip
  • 70 posts

Donator

Posted 23 November 2018 - 06:21 AM

check your phpinfo for the Configuration File (php.ini) Path  to see if its the same path as your edited php.ini

If it's the same, are you able to restart the web service?

#5 patrick8996

patrick8996

    Member

  • Donator
  • PipPip
  • 22 posts
  • LocationOregon

Donator

Posted 23 November 2018 - 06:36 AM

View Postseventeen82, on 23 November 2018 - 06:21 AM, said:

check your phpinfo for the Configuration File (php.ini) Path  to see if its the same path as your edited php.ini

If it's the same, are you able to restart the web service?
I was able to contact my host and apparently IP board is defaulting to the server php.ini instead of my local php.ini

Here is a screenshot of the reply they provided. http://prntscr.com/lltdwm

Is there a way to change where IP Board looks for the php.ini?

Edited by patrick8996, 23 November 2018 - 06:36 AM.


#6 seventeen82

seventeen82

    Advanced Member

  • Member
  • PipPipPip
  • 70 posts

Donator

Posted 23 November 2018 - 06:41 AM

I guess I didn't read your first post well enough the first time around, apologies! I've had this issue with cpanel for a while now, cpanel wants you to have a php.ini or user.ini in the public_html folder (at least in the instances I've encountered) but then I've never been able to get it to load from there.

As far as I know, IPB doesn't load php.ini, thats all on the server environment. I would suggest creating a phpinfo.php file in your root directory and then load that page so it's not "IP Board" setting the default.
  • To create a phpinfo file, open a plain text file, add the following lines, and save:

    Filename: phpinfo.php

    <?php
    
    // Show all information, defaults to INFO_ALL
    phpinfo();
    
    ?>
    


    NOTE:
    Your phpinfo.php file needs to be a plain text file. This means you need to make it in a text editing program capable of producing plain text files.
    • On a Windows machine, you can use Notepad, which is one of your built-in accessories.
    • On a Mac, you can use TextEdit. You must first open the TextEdit "Preferences" menu and, in the "New Document" section, select "Plain text." Then, you should start a new document in TextEdit for your phpinfo.php file.
  • Upload the file to the server. You should upload your file to the exact directory you want to test. Typically, this will be your httpdocs (/var/www/vhosts/example.com/httpdocs/) directory, although you can upload it to any subdirectory on your server as well. Use FTP to upload the file.
  • Visit the page in your browser. If you uploaded it to your html directory, you should now visit http://www.example.com/phpinfo.php, replacing example.com with your own domain name.
  • Now you can view all of the information about PHP for your server for that particular directory.


#7 patrick8996

patrick8996

    Member

  • Donator
  • PipPip
  • 22 posts
  • LocationOregon

Donator

Posted 23 November 2018 - 07:14 AM

View Postseventeen82, on 23 November 2018 - 06:41 AM, said:

I guess I didn't read your first post well enough the first time around, apologies! I've had this issue with cpanel for a while now, cpanel wants you to have a php.ini or user.ini in the public_html folder (at least in the instances I've encountered) but then I've never been able to get it to load from there.

As far as I know, IPB doesn't load php.ini, thats all on the server environment. I would suggest creating a phpinfo.php file in your root directory and then load that page so it's not "IP Board" setting the default.
  • To create a phpinfo file, open a plain text file, add the following lines, and save:

    Filename: phpinfo.php

    <?php
    
    // Show all information, defaults to INFO_ALL
    phpinfo();
    
    ?>
    


    NOTE:
    Your phpinfo.php file needs to be a plain text file. This means you need to make it in a text editing program capable of producing plain text files.
    • On a Windows machine, you can use Notepad, which is one of your built-in accessories.

    • On a Mac, you can use TextEdit. You must first open the TextEdit "Preferences" menu and, in the "New Document" section, select "Plain text." Then, you should start a new document in TextEdit for your phpinfo.php file.
  • Upload the file to the server. You should upload your file to the exact directory you want to test. Typically, this will be your httpdocs (/var/www/vhosts/example.com/httpdocs/) directory, although you can upload it to any subdirectory on your server as well. Use FTP to upload the file.

  • Visit the page in your browser. If you uploaded it to your html directory, you should now visit http://www.example.com/phpinfo.php, replacing example.com with your own domain name.

  • Now you can view all of the information about PHP for your server for that particular directory.
It is showing that is it picking up the default server php.ini. Is there a way to change this? Or a way to force IP board to look else where? I am completely lost as to why this is doing this now. I have not had this issue on any previous version of IP board through this site.

#8 seventeen82

seventeen82

    Advanced Member

  • Member
  • PipPipPip
  • 70 posts

Donator

Posted 23 November 2018 - 07:33 AM

I don't know how ipb would override pho.ini, if anyone else has more knowledge please chime in. To my knowledge, this is a server level thing. IPB runs on php, so it can't change how php works while php is working, if that makes sense.

If you created the phpinfo.php like i linked above, that runs independent of IPB.

I have this issue with one of my clients who uses cpanel with godaddy. Cpanel says you have to put a php.ini or user.ini in the public_html/ dir to override server's php.ini, but I've never successfuly gotten that to work.

If your hoat is willing to modify the server level php.ini, that may be your best option at this point unless anyone else has better insight.

Sorry.

#9 thelinkz

thelinkz

    Hmmm...

  • Community Friend
  • PipPipPipPipPip
  • 419 posts
  • Locationcanada

Posted 23 November 2018 - 07:54 AM

this is your server overriding the phpini

what is the settings in mutiphpini in whm ?



#10 patrick8996

patrick8996

    Member

  • Donator
  • PipPip
  • 22 posts
  • LocationOregon

Donator

Posted 24 November 2018 - 04:29 AM

View Postthelinkz, on 23 November 2018 - 07:54 AM, said:

this is your server overriding the phpini

what is the settings in mutiphpini in whm ?

I do not see an option inside my WHM for multiphp. Is this restricted because I am reselling through a reseller?


EDIT: It actually looks like my host was able to figure this out as the forum software is now reading my own modified php.ini. Thanks for your help guys and this post can be closed and moved.

Edited by patrick8996, 24 November 2018 - 05:09 AM.


#11 thelinkz

thelinkz

    Hmmm...

  • Community Friend
  • PipPipPipPipPip
  • 419 posts
  • Locationcanada

Posted 24 November 2018 - 05:20 AM

glad it got sorted .

yes if your on a reseller account in whm it will be limited .



#12 cold

cold

    Management Team

  • Community Management
  • 670 posts

Donator

Posted 24 November 2018 - 06:20 PM

//closed

Community Rules | IV Discord | News
discord: cold#0001
steam: /id/hitmarker





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users